User Tools

Site Tools


computing:darwin

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revisionPrevious revision
Next revision
Previous revision
Last revisionBoth sides next revision
computing:darwin [2018/05/19 17:12] oemb1905computing:darwin [2019/01/14 02:18] oemb1905
Line 64: Line 64:
   dd if=[Directory/to/udrw/img] of=/dev/disk1 bs=1m   dd if=[Directory/to/udrw/img] of=/dev/disk1 bs=1m
   diskutil eject /dev/disk2   diskutil eject /dev/disk2
-   
-Plug into the Intel Mac, hold option while booting, proceed w/ install 
- 
-Dual Boot gnulinux with macOS 
  
-First, disable Gatekeeper because it is stupid+First, disable Gatekeeper because it is stupid - use Terminal
  
   sudo spctl --master-disable   sudo spctl --master-disable
Line 84: Line 80:
   cd refind-bin-0.11.2   cd refind-bin-0.11.2
   sudo ./refind-install   sudo ./refind-install
 +  sudo reboot
      
-If you are making an .iso of GNU/Linux boot ready for macOS, do the following +-------------------------------------------
-   +
-  diskutil eraseDisk JHFS+ Temp disk# +
-  diskutil unmountDisk force disk#   +
-  sudo dd if=/Users/username/gnulinux-distro.iso of=/dev/disk2 bs=16m && sync+
      
 PATH Location on macOS PATH Location on macOS
Line 118: Line 111:
   sudo dscl . -create /Users/shortnameofuser NSFHomeDirectory /var/shortnameofuser   sudo dscl . -create /Users/shortnameofuser NSFHomeDirectory /var/shortnameofuser
   sudo dscl . -delete "/SharePoints/shortnameofuser's Public Folder"   sudo dscl . -delete "/SharePoints/shortnameofuser's Public Folder"
- +  sudo reboot
-Reboot the Mac +
- +
-------------------------------------------- +
- +
-Homebrew Package Management +
- +
-  ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)" +
-  brew update +
-  brew doctor +
-  brew cleanup +
-  brew upgrade +
-  brew cask install <packagename> +
-  brew install caskroom/cask/<packagename> +
-  git -C "$(brew --repo homebrew/core)" fetch --unshallow +
-   +
-Uninstall Homebrew +
-  Download script from GitHub https://gist.github.com/SteveBenner/11254428 +
- +
-Cask Location, followed by location of currently installed packages ... +
-   +
-  /Volumes/Macintosh HD/usr/local/Library/Taps/caskroom/homebrew-cask/Casks +
-  /Volumes/Macintosh HD/usr/local/Cellar +
-  /Volumes/Macintosh HD/opt/homebrew-cask/Caskroom +
-   +
-Or, run this command to see all installed packages in a txt file in downloads. +
-   +
-  brew list > ~/Downloads/brews.txt +
- +
-Braumeister has a search engine of Homebrew packages - [[http://braumeister.org/]] +
- +
-Common packages worth installing +
- +
-  * tree +
-  * webkit2png +
-  * graphicsmagick +
-  * git +
-  * python +
-  * python3 +
-  * watch +
-  * wget +
-  * automake +
-  * autoconf +
-  * htop +
-  * jpegoptim +
-  * imagemagick +
-  * fish (fish shell) +
-  * xquartz +
-  * Homebrew cask +
-  * ack (like grep) +
-  * git +
-  * bash-completion +
-  * bash completion script +
-  * colordiff +
-  * ffmpeg +
-  * htop +
-  * imagemagick +
-  * gawk +
-  * gnu-sed +
-  * cowsay +
-  * lftp +
-  * wget +
-  * axel +
-  * tree +
-  * unrar +
-  * rlwrap +
-  * readline wrap +
-  * tig +
-  * git (command line interface) +
-  * youtube-dl +
-  * lynx (web browser) +
-  * memcached (for caching on web server) +
-  * Alpine (new version of Pine) +
-  * mutt +
-  * vi +
-  * emacs +
-  * nano +
-  * python (add 3 for v.3) +
-  * pip +
-  * virtualenv +
-  * ruby +
-  * ruby-build (test versions) +
-  * wget +
-  * nmap +
-  * vlc +
-  * gnuplot +
-  * tcpdump +
-  * gnutils +
-  * coreutils +
-  * rsync +
-  * rsnapshot +
-  * binutils +
-  * diffutils +
-  * findutils +
-  * wireless-tools +
-  * screen +
-  * gcc +
-  * openssh +
-  * ssh-copy-id +
- +
-#Path should look like +
- +
-  /usr/local/bin +
-  /usr/local/sbin +
-  /usr/bin +
-  /bin +
-  /usr/sbinMore GNU commands, but duplicate ones +
-  /sbin +
- +
- +
-If you use gnutils or coreutils a lot: +
- +
-  PATH="/usr/local/opt/coreutils/libexec/gnubin:$PATH" +
-  MANPATH="/usr/local/opt/coreutils/libexec/gnuman:$MANPATH" +
- +
-GNU/Linux commands and how to make default +
- +
-  brew tap homebrew/dupes [heals the dupe issue for gnutils] +
-  brew install ed --default-names +
-  brew install findutils --with-default-names +
-  brew install gnu-indent --with-default-names +
-  brew install gnu-sed --with-default-names +
-  brew install gnu-tar --with-default-names +
-  brew install gnu-which --with-default-names +
-  brew install grep --with-default-names +
-  brew install wdiff --with-gettext +
-           +
- +
-Homebrew permissions - only if it gets hosed.  Otherwise, let homebrew installer or brew doctor fix: +
- +
-  sudo chmod -R +a "$USER allow delete,readattr,writeattr,readextattr,writeextattr,readsecurity,writesecurity,chown,list,search,add_file,add_subdirectory,delete_child,file_inherit,directory_inherit"+
-  sudo chown -R root:wheel /usr/local +
-  sudo chmod -R -N /usr/local +
- +
-To install alternative repositories for later installation, such as: +
- +
-  brew install homebrew/<homebrew-binary>/<packagename> +
-  brew tap Homebrew/<homebrew-binary>  +
- +
-  Homebrew/homebrew-apache +
-  Homebrew/homebrew-binary +
-  Homebrew/homebrew-boneyard +
-  Homebrew/homebrew-completions +
-  Homebrew/homebrew-dupes +
-  Homebrew/homebrew-games +
-  Homebrew/homebrew-headonly +
-  Homebrew/homebrew-python +
-  Homebrew/homebrew-science +
-  Homebrew/homebrew-versions +
-  davidchall/homebrew-hep +
-  josegonzalez/homebrew-php  +
- +
--------------------------------------------+
  
 Locate bitcoin wallet private key from Bitcoin-qt console: Locate bitcoin wallet private key from Bitcoin-qt console:
Line 412: Line 253:
   service macfanctld restart   service macfanctld restart
      
 +Chromium API - Q5 - add to ~/.profile
 +
 +  export GOOGLE_API_KEY="AIzaSyAz932CQ2FD3654AKxq3GCE4voQ3eBPuR"
 +  export GOOGLE_DEFAULT_CLIENT_ID="702748309358-4f29qgd9h1qgla7l0l4sh15lrj1livs0.apps.googleusercontent.com"
 +  export GOOGLE_DEFAULT_CLIENT_SECRET="OZ3G8hpcHiw77l_Jh_IDJuz"
 +
 +To run the program, you must make a shell script that does:
 +
 +  /Applications/Chromium.app/Contents/MacOS/Chromium
 +
 +Remove the annoying Gatekeeper ban on open source apps like GIMP
 +
 +  xattr -d com.apple.quarantine /Volumes/macos/Applications/GIMP-2.10.app
  
 +This tutorial is a designated "Invariant Section" of the "Technotronic" section of Haack's Wiki as described on the [[https://jonathanhaack.com/dokuwiki/doku.php?id=start|Start Page]].
  
  --- //[[netcmnd@jonathanhaack.com|oemb1905]] 2017/05/15 04:26//  --- //[[netcmnd@jonathanhaack.com|oemb1905]] 2017/05/15 04:26//
  
computing/darwin.txt · Last modified: 2020/02/12 01:02 by oemb1905