User Tools

Site Tools


computing:darwin

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revisionPrevious revision
Next revision
Previous revision
Last revisionBoth sides next revision
computing:darwin [2016/04/24 04:31] oemb1905computing:darwin [2019/01/14 02:18] oemb1905
Line 1: Line 1:
-#Darwin Basics +------------------------------------------- 
-#Jonathan Haack +  * **darwin**  
-#Haack's Networking +  * **Jonathan Haack** 
-#netcmnd@jonathanhaack.com+  * **Haack's Networking** 
 +  * **netcmnd@jonathanhaack.com** 
  
 ------------------------------------------- -------------------------------------------
-#Path+Making a bootable usb stick ...
  
-  /etc/paths (location of PATH on Mac) +  diskutil list 
-  /etc/man.path (man page paths)+  diskutil eraseDisk <filesystemtype> <partitionname> <diskidentifier> 
 +  diskutil unmountDisk <diskidentifier>
  
-#Force Remove Trash+Examples
  
-#User Directory Trashes (sudo not required, but can help) +  sudo dd if=/Volumes/Cave/Users/axes/Desktop/lubuntu.iso of=/dev/disk4 bs=1m 
-  sudo rm -rf ~/.Trash/* +  sudo dd if=/Users/me/tails-i386-1.3.iso of=/dev/rdisk9 bs=16m && sync
-   +
-#All Directory Trashes (sudo not required, but can help) +
-  sudo rm -rf /Volumes/*/.Trashes+
  
-#If this still causes troublethen +Insert USB drive into PPC Mac of choicedepress command-option-o-f (open firmware) 
-  login root+try usb0, usb1, usb2, etc. until it works and finds the port you used for the img
  
-#Enter password +  probe-usb 
-  sudo rm -rf /Volumes/*/.Trashes+  boot usb0/disk@1:2,\\yaboot 
 +  boot usb1/disk@1:2,\\yaboot 
  
-#Nowall trashes should empty, but it is slow so view +once inside the yaboot shellsome common examples are:
-#Finder Status bar at /Volumes/Macintosh HD/+
  
-#Showing hidden items in Finder (highly recommended)+  install url=mintppc.org 
 +  install 
 +  cli   
 +  cli-expert 
 +  cli64 
 +  cli64-expert
  
-  defaults write com.apple.finder AppleShowAllFiles TRUE 
-  killall Finder 
  
-#replace with FALSE to change back ... make sure before entering killall +------------------------------------------- 
-#could also use YES / NOor 1/0 (have not tested 1/0)+#**wireless hardware driversb43 cutter +** 
 +-------------------------------------------
  
-#Hiding Users+  deb http://httpredir.debian.org/debian/ wheezy main contrib non-free 
 +  deb http://http.debian.net/debian/ jessie main contrib non-free 
 +  apt-get update 
 +  sudo lspci 
 +  apt-get install firmware-b43-installer 
 +  apt-get install firmware-b43-lpphy-installer 
 +  apt-get install firmware-b43legacy-installer
  
-  sudo dscl . create /Users/shortnameofuser IsHidden 1 +use lspci above and then visit https://wiki.debian.org/bcm43xx#supported-b43
- +
-#change to 0 to de-activate +
- +
-#Moving user directory to var (warning, do this logged in as root) +
-  sudo mv /Users/shortnameofuser /var/shortnameofuser +
- +
-#Then, update the user record path +
-  sudo dscl -create /Users/shortnameofuser NSFHomeDirectory /var/shortnameofuser +
- +
-#Remove public share point through Terminal (or go to FS in SP in GUI) +
-  sudo dscl . -delete "/SharePoints/shortnameofuser's Public Folder"+
  
 ------------------------------------------- -------------------------------------------
  
-#Homebrew Basics+32bit EFI 64bit .iso notes for GNU/Linux installs 
  
-#Install: +  hdiutil convert -format UDRW -o destination_file.img source_file.iso 
-  ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"+  diskutil list 
 +  diskutil partitionDisk /dev/disk1 1 "Free Space" "unused" "100%"
  
-#Uninstall: +Particularly helpful is partitioning as GPT from command line in macOS:  
-  Download script from GitHub https://gist.github.com/SteveBenner/11254428+
  
-#Update +  diskutil partitionDisk /dev/disk2 GPT JHFS+ New 0b 
-  brew update+   
 +Back to writing the image to the partition with dd: 
 +   
 +  dd if=[Directory/to/udrw/img] of=/dev/disk1 bs=1m 
 +  diskutil eject /dev/disk2
  
-#Cleanup: +First, disable Gatekeeper because it is stupid - use Terminal
-  brew cleanup+
  
-#Verify Config: +  sudo spctl --master-disable
-  brew doctor+
  
-#Update Packages +Second, disable System Integrity Protection (SIP) because it is stupid and won't let you dual boot properly.  Reboot your Mac, holding down command + r, and once in the recovery OS, open a Terminal and enter:
-  brew update packagename+
  
-#Install from Casks +  csrutil disable
-  brew install Caskroom/cask/nameofcasknoextension +
- +
-#To find the Casks in your GUI +
-  /Volumes/Macintosh HD/usr/local/Library/Taps/caskroom/homebrew-cask/Casks +
- +
-#To see what you have installed using your GUI +
-  /Volumes/Macintosh HD/usr/local/Cellar +
- +
-#Sometimes they are installed by default in opt +
-#(although this can be changed by an --option) +
-  /Volumes/Macintosh HD/opt/homebrew-cask/Caskroom+
  
 +Now, reboot your Mac normally and enter a Terminal.
 +  
 +  cd ~
 +  wget https://sourceforge.net/projects/refind/files/0.11.2/refind-bin-0.11.2.zip
 +  unzip refind-bin-0.11.2.zip
 +  cd refind-bin-0.11.2
 +  sudo ./refind-install
 +  sudo reboot
 +  
 ------------------------------------------- -------------------------------------------
 +  
 +PATH Location on macOS
  
-#There is debate, mostly from MacPorts & Fink people +  /Sometimes they are installed by default in opt 
-#about where to put package Managers:+#(although this can be changed by an --option)etc/paths (location of PATH on Mac) 
 +  /etc/man.path (man page paths)
  
-#Homebrew will cause problems when building software from source if it is installed in /usr/local.+Force Empty Trashes  
 +  sudo rm -rf ~/.Trash/* 
 +  sudo rm -rf /Volumes/*/.Trashes
  
-#This is the default, which is a bad choice as this path is in the default search path of compilers and other tools. 
- 
-#Therefore builds from other packaging software might pick up the wrong dependency, using Homebrew's version instead of their own. 
- 
-#Years ago, in the very beginning of the project, even MacPorts was using /usr/local. 
- 
-#But it turned out not to cooperate with other tools as is documented in their FAQ. 
- 
-#Unfortunately Homebrew developers didn't want to hear about prior experiences and ignored such facts... 
-#In general, it is usually better to stick to one tool only to avoid all problems. 
-#MacPorts is doing their best to patch out any harcoded paths, e.g. to /sw which is used by Fink. 
-#So usually it will work, but having anything installed in /usr/local will definitely cause problems for it. 
- 
-@Raim on StackExchange  
-[[https://superuser.com/questions/181337/is-it-safe-to-install-both-homebrew-and-macports-on-the-same-machine]] 
- 
-#MacPorts addresses this too: 
-[[https://trac.macports.org/wiki/FAQ#defaultprefix]] 
  
 ------------------------------------------- -------------------------------------------
  
-#Braumeister has a search engine of Homebrew packages+Showing hidden items in Finder
  
-[[http://braumeister.org/]]+  defaults write com.apple.finder AppleShowAllFiles TRUE 
 +  killall Finder
  
-------------------------------------------- 
- 
-#Common Packages (Will be adding more, this is by no means 
-#exhaustive of what I have used in past). 
- 
-  * tree 
-  * webkit2png 
-  * graphicsmagick 
-  * git 
-  * python 
-  * python3 
-  * watch 
-  * wget 
-  * automake 
-  * autoconf 
-  * htop 
-  * jpegoptim 
-  * imagemagick 
-  * fish (fish shell) 
-  * xquartz 
-  * Homebrew cask 
-  * ack (like grep) 
-  * git 
-  * bash-completion 
-  * bash completion script 
-  * colordiff 
-  * ffmpeg 
-  * htop 
-  * imagemagick 
-  * gawk 
-  * gnu-sed 
-  * cowsay 
-  * lftp 
-  * wget 
-  * axel 
-  * tree 
-  * unrar 
-  * rlwrap 
-  * readline wrap 
-  * tig 
-  * git (command line interface) 
-  * youtube-dl 
-  * lynx (web browser) 
-  * memcached (for caching on web server) 
-  * Alpine (new version of Pine) 
-  * mutt 
-  * vi 
-  * emacs 
-  * nano 
-  * python (add 3 for v.3) 
-  * pip 
-  * virtualenv 
-  * ruby 
-  * ruby-build (test versions) 
  
 ------------------------------------------- -------------------------------------------
  
-#Install GNU Essentials+Hiding Users in macOS.  First, create an admin user in System Preferences.  
  
-  brew install coreutils+  sudo dscl . create /Users/shortnameofuser IsHidden 1 
 +  sudo mv /Users/shortnameofuser /var/shortnameofuser 
 +  sudo dscl . -create /Users/shortnameofuser NSFHomeDirectory /var/shortnameofuser 
 +  sudo dscl . -delete "/SharePoints/shortnameofuser's Public Folder" 
 +  sudo reboot
  
-#Add to PATH with TextWrangler or: +Locate bitcoin wallet private key from Bitcoin-qt console:
-  sudo open /etc/paths +
-  sudo nano /etc/paths+
  
-#Add the next line after /usr/bin +  walletpassphrase [enterpassword] 
-  /usr/local/bin +  dumprivkey [enter public address from gui]
- +
-#Add to PATH with vi text editor or nano using Terminal +
-  sudo vi /etc/paths +
-  sudo nano /etc/paths +
- +
-#Path Looks Like This, but bear in mind Homebrew prefers the local bin first +
- +
-  /usr/bin +
-  /usr/local/bin +
-  /bin +
-  /usr/sbin +
-  /sbin +
- +
-#Homebrew offers the following instructions about coreutils +
- +
-#All commands have been installed with the prefix 'g'+
- +
-#If you really need to use these commands with their normal name can +
-#add a "gnubin" directory to your PATH from your bashrc like +
-  PATH="/usr/local/opt/coreutils/libexec/gnubin:$PATH" +
- +
-#Additionally, you can access their man pages with normal names the +
-#"gnuman" directory to your MANPATH from your bashrc as well +
-  MANPATH="/usr/local/opt/coreutils/libexec/gnuman:$MANPATH" +
- +
-#You can also use Text Wrangler to add the GNU commands to Man Pages (or use vi) +
-  /etc/man.conf +
-   +
-#add the following in the Set up PATH to MANPATH mapping section +
-  MANPATH_MAP /usr/local/opt/coreutils/libexec/gnubin +
- /usr/local/opt/coreutils/libexec/gnuman+
  
 ------------------------------------------- -------------------------------------------
  
-#More GNU commandsbut duplicate ones+To add shell scripts to Terminal commandopen bash.rc, and add this to the fields (first create a directory for your scripts):
  
-  brew tap homebrew/dupes+  export PATH="/path/to/dir:$PATH"
  
-  brew install binutils +#Then, restart Terminal by:
-  brew install diffutils +
-  brew install ed --default-names +
-  brew install findutils --with-default-names +
-  brew install gawk +
-  brew install gnu-indent --with-default-names +
-  brew install gnu-sed --with-default-names +
-  brew install gnu-tar --with-default-names +
-  brew install gnu-which --with-default-names +
-  brew install gnutls +
-  brew install grep --with-default-names +
-  brew install gzip +
-  brew install screen +
-  brew install watch +
-  brew install wdiff --with-gettext +
-  brew install wget+
  
-#newer versions of tools already on OS X and GNU+  source .bashrc
  
-  brew install bash +#I also added the directory of my shell scripts to the path directory
-  brew install emacs +
-  brew install gdb   gdb requires further actions to make it work. See `brew info gdb`. +
-  brew install gpatch +
-  brew install m4 +
-  brew install make +
-  brew install nano+
  
-#commands not on GNU but on OS X but might want newer+  cd Volumes/Cave/etc/ 
 +  nano edit paths 
  
-  brew install file-formula +#Then add a line to the scripts folder:
-  brew install git +
-  brew install less +
-  brew install openssh +
-  brew install perl518    must run "brew tap homebrew/versions" first! +
-  brew install python +
-  brew install rsync +
-  brew install svn +
-  brew install unzip +
-  brew install vim --override-system-vi +
-  brew install macvim --override-system-vim --custom-system-icons +
-  brew install zsh+
  
--------------------------------------------+  /Volumes/Cave/Users/axes/Scripts
  
-#Adding scripts to my shell PATH so I can run form command line+#To make a script executable (not tested yet - old commands in fodler)
  
-  ln -s /Volumes/Cave/<path-to-script> /usr/local/bin/scriptname+  chmod +x yourshellscript.sh
  
 ------------------------------------------- -------------------------------------------
  
-#To see what is currently installed and save text file in User Downloads+#El Capitan Boot Volume command - presuming it is in the Applications directory and is the GM Candidate version ... if not, substitute in version / title of the one you have:
  
-  brew list > ~/Downloads/brews.txt+  sudo /Applications/Install\ OS\ X\ El\ Capitan\ GM\ Candidate.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled --applicationpath /Applications/Install\ OS\ X\ El\ Capitan\ GM\ Candidate.app --nointeraction
  
 ------------------------------------------- -------------------------------------------
  
-#Remember, there are third party caskrooms (braumeister has lots of info):+#OS X Server Settings
  
-  homebrew/science/metaphlan        +#To require binding
-  Caskroom/cask/tap-bpm             +
-  Caskroom/cask/tuntap              +
-  Caskroom/cask/wiretap-studio    +
-  Caskroom/cask/rcdefaultapp        +
-  Caskroom/cask/tapaal              +
-  Caskroom/cask/wavtap           +
  
-#To install one of themrun (for example)+  sudo slapconfig -setmacosxodpolicy -binding required 
-  brew install homebrew/science/metaphlan +   
-     +#To rebuild an Open Directory if nothing else works (Quit ServerRun Command, Restart CPU)
--------------------------------------------+
  
-#Some error readings I got once ... still need to review ... copied and paster below:+  sudo slapconfig -destroyldapserver
  
-Are you sure you want to uninstall Homebrew? [y/N] y +#Making an alias called "fix_brew" 
-==> Removing Homebrew installation... +  alias fix_brew='sudo chown -R $USER /usr/local/'
-==> Removing empty directories... +
-==> Homebrew uninstalled! +
-The following possible Homebrew files were not deleted: +
-  *   /usr/local/.DS_Store +
-  *   /usr/local/bin/ +
-  *   /usr/local/share/ +
-You may consider to remove them by yourself. +
- +
-#You may want to restore /usr/local's original permissions +
-  sudo chmod 0755 /usr/local +
-  sudo chgrp wheel /usr/local+
      
--------------------------------------------+#preferred way of re-owning homebrew is to use this command below 
 +  sudo chown -R `whoami` /usr/local/ 
 +#or 
 +  sudo chown -R $USER /usr/local/
  
-#Permissions to manually allow everything for a user +#disable System Integrity Protection 
-#The second command owns a directory by root with group wheel over local directory +  csrutil disable 
-#The third restores current user as owner to local directory +  csrutil enable 
- +  csrutil status
-  sudo chmod -R +a "$USER allow delete,readattr,writeattr,readextattr,writeextattr,readsecurity,writesecurity,chown,list,search,add_file,add_subdirectory,delete_child,file_inherit,directory_inherit"+
- +
-  sudo chown -R root:wheel /usr/local +
-  sudo chmod -R -N /usr/local +
- +
--------------------------------------------+
      
-#To install alternative repositories for later installation, such as:+#change gatekeeper settings or disable entirely or re-enable 
 +  spctl --status 
 +  sudo spctl --master-enable 
 +  spctl --add /Path/To/Application.app 
 +   
 +#Making a shell script executable 
 +  sudo chmod 700 file.sh
  
-  Homebrew/homebrew-apache +#verifying checksum 
-  Homebrew/homebrew-binary +  shasum /path/to/file.extension
-  Homebrew/homebrew-boneyard +
-  Homebrew/homebrew-completions +
-  Homebrew/homebrew-dupes +
-  Homebrew/homebrew-games +
-  Homebrew/homebrew-headonly +
-  Homebrew/homebrew-python +
-  Homebrew/homebrew-science +
-  Homebrew/homebrew-versions +
-  davidchall/homebrew-hep +
-  josegonzalez/homebrew-php+
  
-  brew tap Homebrew/homebrew-binary  +#make tarball dokuwiki 
 +  tar zcpfv dokuwiki-backup.tar.gz /path/to/dokuwiki 
 +  
 +#ssh key pair ... later 
 +  ssh 
  
-#To install the brew tap third party packages, look inside the Taps folder in /usr/local to find one, and then+#disable ssh on *nix machines
  
- brew install homebrew/homebrew-games/<name of package>+  su - root 
 +  cd /etc/ssh/ 
 +  nano sshd_config
  
-#Some are not strict directory paths, but are abbreviations (most likely through the bin somehow+#change the following lines and make sure to remove comment (#... 
-  brew install Caskroom/cask/[name of package from step ^] +  ChallengeResponseAuthentication no 
 +  PasswordAuthentication no 
 +  UsePAM no
  
--------------------------------------------+#restart ssh which on linux is below ... macOS uses launchd so not sure yet 
 +  /etc/init.d/sshd restart 
 +   
 +#add user from command line should prompt for password 
 +  sudo sysadminctl -addUser <exampleuser> -password - -admin 
 +   
 +#Changing tempermental host name 
 +  sudo scutil --set ComputerName "newname" 
 +  sudo scutil --set LocalHostName "newname" 
 +  sudo scutil --set HostName "newname" 
 +  dscacheutil -flushcache
  
-#To get private key from bitcoin console +#pimp bash profile 
-#Navigate to bitcoin console+  nano ~/.bash_profile 
 +  export PS1="\[\033[36m\]\u\[\033[m\]@\[\033[32m\]\h:\[\033[33;1m\]\w\[\033[m\]\$ " 
 +  export CLICOLOR=1 
 +  export LSCOLORS=ExFxBxDxCxegedabagacad 
 +  #alias ls='ls -GFh' 
 +  alias l='ls' 
 +  alias ll='ls -lah'
  
-  walletpassphrase [enterpassword] +#sfcc server - use for thunderbird on macOS and on gnulinux 
-  dumprivkey [enter public address from gui]+  https://archimedes.sfcc.edu/EWS/Exchange.asmx 
 +   
 +#homebrew changed path ... add sbin to default PATH ... 
 +  echo 'export PATH="/usr/local/sbin:$PATH"' >> ~/.bash_profile 
 +   
 +#homebrew remove shallow
  
-#Out comes the private key+    git -C "$(brew --repo homebrew/core)" fetch --unshallow 
 +   
 +Apache .htaccess syntax for BSD, macOS, and Red Hat: 
 +   
 +  sudo htpasswd -c .htpasswd username1 
 +  sudo htpasswd .htpasswd username2 
 +   
 +  AuthUserFile /private/etc/httpd/.htpasswd  
 +  AuthGroupFile /dev/null 
 +  AuthName "Members Only" 
 +  AuthType Basic
  
--------------------------------------------+  <Limit GET POST>  
 +  require valid-user 
 +  </Limit> 
 +  
 +If you have an SMC based Mac, make sure to install macfanctl when installing GNU/Linux on the device:
  
-#To add shell scripts to Terminal command, open bash.rc, and add this to the fields (first create a directory for your scripts):+  apt-get update 
 +  apt-get install macfanctld 
 +  /etc/macfanctl.conf 
 +  <set desired values> 
 +  service macfanctld restart 
 +   
 +Chromium API - Q5 - add to ~/.profile
  
-  export PATH="/path/to/dir:$PATH"+  export GOOGLE_API_KEY="AIzaSyAz932CQ2FD3654AKxq3GCE4voQ3eBPuR" 
 +  export GOOGLE_DEFAULT_CLIENT_ID="702748309358-4f29qgd9h1qgla7l0l4sh15lrj1livs0.apps.googleusercontent.com" 
 +  export GOOGLE_DEFAULT_CLIENT_SECRET="OZ3G8hpcHiw77l_Jh_IDJuz"
  
-#Thenrestart Terminal by:+To run the programyou must make a shell script that does:
  
-  source .bashrc +  /Applications/Chromium.app/Contents/MacOS/Chromium
- +
-#I also added the directory of my shell scripts to the path directory +
- +
-  cd Volumes/Cave/etc/ +
-  nano edit paths  +
- +
-#Then add a line to the scripts folder: +
- +
-  /Volumes/Cave/Users/axes/Scripts +
- +
-#To make a script executable (not tested yet - old commands in fodler) +
- +
-  chmod +x yourshellscript.sh +
- +
-------------------------------------------- +
- +
-#El Capitan Boot Volume command - presuming it is in the Applications directory and is the GM Candidate version ... if not, substitute in version title of the one you have: +
- +
-  sudo /Applications/Install\ OS\ X\ El\ Capitan\ GM\ Candidate.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled --applicationpath /Applications/Install\ OS\ X\ El\ Capitan\ GM\ Candidate.app --nointeraction+
  
 +Remove the annoying Gatekeeper ban on open source apps like GIMP
  
 +  xattr -d com.apple.quarantine /Volumes/macos/Applications/GIMP-2.10.app
  
 +This tutorial is a designated "Invariant Section" of the "Technotronic" section of Haack's Wiki as described on the [[https://jonathanhaack.com/dokuwiki/doku.php?id=start|Start Page]].
  
 + --- //[[netcmnd@jonathanhaack.com|oemb1905]] 2017/05/15 04:26//
  
computing/darwin.txt · Last modified: 2020/02/12 01:02 by oemb1905