User Tools

Site Tools


computing:exim4

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revisionPrevious revision
Next revisionBoth sides next revision
computing:exim4 [2021/10/30 12:07] oemb1905computing:exim4 [2021/10/30 12:41] oemb1905
Line 188: Line 188:
   exim -Mvh <message id>   exim -Mvh <message id>
   exim -bp | awk '/^ *[0-9]+[mhd]/{print "exim -Mrm " $3}' | bash   exim -bp | awk '/^ *[0-9]+[mhd]/{print "exim -Mrm " $3}' | bash
 +
 +TLS can pitch an annoying warning that states "TLS connections will fail. Suggested action: either install a certificate or change tls_advertise_hosts option."  I should not be getting this Warning, nor should I have to change any options in the config, since I am already advertising TLS and properly accepting smtp connections from it (see swaks output above).  Most online resources talk about getting this warning when it is a false positive, but in this case, it is false negative, meaning it is saying I don't have this but I do.  Here's how to suppress the irrelevant and in this case, incorrect, warning:
 +
 +  sudo nano /etc/exim4/exim4.conf.template
 +  
 +Search for "A weaker form" and once you get to that section look for where it states ''.else'' and then "Use upstream defaults" and then closes with ''.endif'' - right in between else/endif, put the following line:
 +
 +  tls_advertise_hosts =
 +
 +Just so you are clear, it will look like this:
 +
 +
  
  --- //[[jonathan@haacksnetworking.com|oemb1905]] 2021/10/30 12:05//  --- //[[jonathan@haacksnetworking.com|oemb1905]] 2021/10/30 12:05//
computing/exim4.txt · Last modified: 2022/08/20 00:11 by oemb1905